Laptop screen goes blank

I have a strange issue with VMSpc on my laptop. If I have the program running before I start the engine it works until I start to crank the engine and then the monitor will go blank and it losses connection to the JIB. When the engine starts I have to restart VMSpc, then it's OK. I have the communication set to restart in the advanced setting. This has been an issue since I upgraded to Windows 10. Does anyone have a suggestion? It's a Samsung Laptop. Thanks

re: Screen goes blank on engine cranking

So let me get this straight: the screen blanks out--goes dark--on cranking. Or...is it that you observe the gauges going to zero?

Hello Richard
This is rather peculiar.
1. Is the JIB being used on a hub--or straight to the laptop?
2. On battery power or plugged-in?
3. JIB plugged in using a standard cable, pigtail or something else?

Inquiring minds...

Art
//

Screen goes blank on engine cranking

Hi Art

Screen goes black. No gauges.
The JIB is plugged into a powered hub. There is also a 7" monitor on the hub I use for the VMSpc program. Both go black.
I'm using a standard usb cables.

Richard

re: Black screens

As I suspected--a hub issue.

Its very likely that during the JIBs quick power-cycle (OFF-RUN-Start-RUN) Windows re-orgs the USB devices to save power.

This, if in fact the case, may be remedied via device manager.
1. Open it via the Communications window.
2. From the top-line menu items, select View > Hidden Devices.
3. Open each item under Display (adapters) and Universal Serial Bus Adapters, one at a time.
4. When one has a Power Management tab, select it. Uncheck any box labeled 'Let Windows save power...' Afterwards, reboot and try it again.

It may be this power saving blanking the screens while Windows reorganizes the posts when power is intermittently lost. VMSpc can't natively blank your screen. And, having a second monitor introduces a peculiar twist for power management. Alternatively, if the hub is being powered by the ignition, wire it instead to a full time power source, adding a power switch to disable it as needed.

And... keep us posted

cheers

Art
//

re: Black screens

I finally had some time to work on this. There seemed to be 2 issues. Changing the power settings for the USB ports fixed the main Laptop screen from going black during starting but the little monitor I have still did the same thing. After some testing - plugging the monitor directly into the laptop solved that problem. The monitor has 2 USB plugs on one cable. I re-read the documentation and with a powered hub only one is required. I plugged it back into the hub only using one of the plugs and everything is working. Thank you so much for pointing me in the right direction.

Rich